Broken install

  • 3 Replies
  • 585 Views
*

Offline joslel

  • **
  • 1
  • +0/-0
Broken install
« on: August 23, 2017, 07:33:14 pm »
Hi! I recently made the switch from an old TBDev server I've been running, so this problem may have an easy solution that I don't know about.

I've made a fresh install with XBTiT 2.5.4, PHP tracker and internal forum, and none of the theme/style images show up when I load the site. This happens both before and after successful installation. My error-logs aren't returning anything.

The rest of the site is very broken, but I can't tell if it's an install issue or just missing image files.

It's currently running on PHP 7.1.

I have doublechecked and reuploaded every directory, reinstalled, chmod'ed various files and folders, but can't seem to effect it the slightes. What am I missing?

Thanks!

edit: Now I recieved this error message: [23-Aug-2017 20:08:33 Europe/Berlin] PHP Notice:  unserialize(): Error at offset 0 of 25 bytes in /home/kongaqxo/public_html/passord/include/config.php on line 188

Could it be related? Search results don't seem to be showing the same issues that I'm experiencing.
« Last Edit: August 23, 2017, 08:10:16 pm by joslel »

*

Offline Yupy

  • ****
  • 1,141
  • +0/-0
    • ...:::MidnightXpress:::...
Re: Broken install
« Reply #1 on: August 26, 2017, 10:44:02 pm »
Do you see the text?

Also disable GZIP maybe will show some errors, I'm aware about an issue with it but I forgot what I have done to make it work.

*

Offline King Cobra

  • XBTIT Maintainer / Developer
  • *****
  • 516
  • +0/-0
  • xbtitFM Administrator
Re: Broken install
« Reply #2 on: August 27, 2017, 10:27:19 am »
That php notice is for this code in the include/config.php
Code: [Select]
$TRACKER_ANNOUNCE_URL=unserialize(base64_decode($btit_settings['announce']));

*

Offline Yupy

  • ****
  • 1,141
  • +0/-0
    • ...:::MidnightXpress:::...
Re: Broken install
« Reply #3 on: August 28, 2017, 10:03:20 pm »
PHP Notices are not actually bugs but you can encode it before decode (Not tested but should solve the Notice).

Replace:

Code: [Select]
$TRACKER_ANNOUNCE_URL=unserialize(base64_decode($btit_settings['announce']));
With:

Code: [Select]
$TRACKER_ANNOUNCE_URL = base64_encode(serialize($btit_settings['announce']));
$TRACKER_ANNOUNCE_URL=unserialize(base64_decode($btit_settings['announce']));
« Last Edit: August 28, 2017, 10:05:11 pm by Yupy »

 


Powered by EzPortal