Website redirecting to localhost

  • 6 Replies
  • 3523 Views
*

Offline numbvox

  • **
  • 6
  • +0/-0
Website redirecting to localhost
« on: August 10, 2016, 04:07:50 am »
Hi guys,

I'm having an issue with the xbtit site redirecting to localhost. I have SMF installed and it works perfectly, it's only the tracker part of the site that is redirecting to localhost. Any ideas why this is happening? I check the configs and the url is set to the domain.

It all was working fine until this evening.

*

Offline King Cobra

  • XBTIT Maintainer / Developer
  • *****
  • 540
  • +0/-0
  • xbtitFM Administrator
Re: Website redirecting to localhost
« Reply #1 on: August 10, 2016, 04:26:42 am »
what xbtit version you running?
Are you hosting the tracker yourself on a computer you own or on the web it's hosted at?

*

Offline numbvox

  • **
  • 6
  • +0/-0
Re: Website redirecting to localhost
« Reply #2 on: August 11, 2016, 01:49:33 am »
I'm running xbtit 2.5.1 on a VPS running centos 6.8 with CWP.admin control panel.

Not sure why it's all of the sudden redirecting to localhost, it was working fine and I opted for the SMF integration and SMF runs fine and loads.. I have a vbulletin forum on the same box and it's running fine. Strange, I'm sure I must have done something, I just don't know what I could have done. lol

*

Offline King Cobra

  • XBTIT Maintainer / Developer
  • *****
  • 540
  • +0/-0
  • xbtitFM Administrator
Re: Website redirecting to localhost
« Reply #3 on: August 11, 2016, 03:36:35 am »
I'm running xbtit 2.5.1 on a VPS running centos 6.8 with CWP.admin control panel.

Not sure why it's all of the sudden redirecting to localhost, it was working fine and I opted for the SMF integration and SMF runs fine and loads.. I have a vbulletin forum on the same box and it's running fine. Strange, I'm sure I must have done something, I just don't know what I could have done. lol
did you add any new files to the tracker like a new hack or module?
if so you need to go into your CWP.admin control panel & go into user accounts & then to fix permissions & then to the the user on the tracker you have setup
once done check your tracker see if it works again

*

Offline numbvox

  • **
  • 6
  • +0/-0
Re: Website redirecting to localhost
« Reply #4 on: August 11, 2016, 04:03:12 am »
I did add the signature mod. I did notice the the include/config.php file referenced localhost so I updated it to my url and that got the site back up and running. ;-) But now I see the following:

Quote
Warning: array_key_exists() expects parameter 2 to be array, boolean given in /home/vox/public_html/x/include/config.php on line 78

Notice: Undefined index: secsui_cookie_type in /home/vox/public_html/x/include/functions.php on line 506

Notice: Undefined index: secsui_cookie_type in /home/vox/public_html/x/include/functions.php on line 508

Notice: Undefined index: secsui_cookie_type in /home/vox/public_html/x/include/functions.php on line 519

Notice: Undefined index: secsui_cookie_type in /home/vox/public_html/x/include/functions.php on line 506

Notice: Undefined index: secsui_cookie_type in /home/vox/public_html/x/include/functions.php on line 508

Notice: Undefined index: secsui_cookie_type in /home/vox/public_html/x/include/functions.php on line 519

Notice: Undefined index: HTTP_ACCEPT_ENCODING in /home/vox/public_html/x/index.php on line 332

*

Offline numbvox

  • **
  • 6
  • +0/-0
Re: Website redirecting to localhost
« Reply #5 on: August 20, 2016, 08:22:14 pm »
I guess I need to completely reinstall the script? Surely there is a way to fix the  secsui_cookie_type issue without redoing everything.

*

Gh0st4unt3r

Re: Website redirecting to localhost
« Reply #6 on: August 21, 2016, 10:05:59 pm »
Can you please put this onto our github page where the project is on so we can track and solve this for you, We have a range of developers within github to get this resolved for you.

 


Powered by EzPortal