XBT reports peers=0 to xbtit

  • 13 Replies
  • 4707 Views
*

neokobe

XBT reports peers=0 to xbtit
« on: May 23, 2012, 11:33:01 pm »
1 / Operating System: Windows XP SP3
2 / version xbtit: 2.3.0 rev748
3 / hack installed: none
4 / problems encountered: XBT works OK, but doesn't report the peers to xbtit.
5 / url of site: http://monk.kicks-ass.org

Extra info:
XBT version: 0.2.9

Hi,
I've been running a torrent site for a few weeks now, and yesterday I installed XBT 0.2.9.
XBT works ok, but the reported stats in xbtit shows 0 peers. I checked the XBT stats by doing url:2710/stats and they show properly there.
This is not critical, as the site has a small userbase and can fall back to PHP tracker, but I would like to get this fixed so I can use XBT.
Can anyone please point me in the right direction?

EDIT: I forgot to add, also torrent history doesn't work (last upload & top torrents)
« Last Edit: May 24, 2012, 06:14:24 am by neokobe »

*

Offline Lupin

  • *****
  • 10,985
  • +0/-0
    • http://www.btiteam.org
Re: XBT reports peers=0 to xbtit
« Reply #1 on: May 25, 2012, 01:42:34 pm »
xbtt and xbtit MUST share the same database
Please don't PM me about question already asked in forum!

Help or support requested using PM will be billed 50 euros/hour, minimum 1 hour; support on forum is free.

*

neokobe

Re: XBT reports peers=0 to xbtit
« Reply #2 on: May 28, 2012, 02:45:10 pm »
I know, xbtt and xbtit share the same database.

The only thing that seems out of place is the xbtt entries being InnoDB instead of MyISAM. Does xbtt or xbtit have any problem reading InnoDB that you are aware of? Thanks for your concern.

EDIT: Changing the engine on the tables from InnoDB to MyISAM did not have any effect, the number of peers reseted to 0.
« Last Edit: May 28, 2012, 07:20:42 pm by neokobe »

*

Offline psychocydd

  • Box Beast on Weed
  • *****
  • 1,185
  • +0/-0
    • RockBox
Re: XBT reports peers=0 to xbtit
« Reply #3 on: May 28, 2012, 07:34:55 pm »
i use xbt with InnoDB so that has nothing to do with it.

so your db is not getting propagated with the amount of seeders and leechers or it is and its the site (frontend) thats not showing them?

*

neokobe

Re: XBT reports peers=0 to xbtit
« Reply #4 on: May 29, 2012, 03:30:19 am »
Sorry I wasn't clear enough, the database doesn't get propagated with the ammount of seeders/leechers, all entries show 0.

*

Offline Lupin

  • *****
  • 10,985
  • +0/-0
    • http://www.btiteam.org
Re: XBT reports peers=0 to xbtit
« Reply #5 on: May 29, 2012, 10:00:08 am »
try to restart xbtt
Please don't PM me about question already asked in forum!

Help or support requested using PM will be billed 50 euros/hour, minimum 1 hour; support on forum is free.

*

neokobe

Re: XBT reports peers=0 to xbtit
« Reply #6 on: May 29, 2012, 07:10:49 pm »
I restarted the XBT Tracker service a couple times, but it has no effect.

*

Offline Lupin

  • *****
  • 10,985
  • +0/-0
    • http://www.btiteam.org
Re: XBT reports peers=0 to xbtit
« Reply #7 on: May 30, 2012, 09:10:52 am »
if you have private announce off (public tracker) then xbtt don't register stats
Please don't PM me about question already asked in forum!

Help or support requested using PM will be billed 50 euros/hour, minimum 1 hour; support on forum is free.

*

neokobe

Re: XBT reports peers=0 to xbtit
« Reply #8 on: May 30, 2012, 03:27:56 pm »
Private announce is on, I will post a few images showing current configuration:

xbtit Tracker's Settings 1


xbtit Tracker's Settings 2


xbt url:2710/stats


xbt_tracker.conf

*

Offline Lupin

  • *****
  • 10,985
  • +0/-0
    • http://www.btiteam.org
Re: XBT reports peers=0 to xbtit
« Reply #9 on: May 31, 2012, 09:33:41 am »
look if your xbt_files_users is filled
Please don't PM me about question already asked in forum!

Help or support requested using PM will be billed 50 euros/hour, minimum 1 hour; support on forum is free.

*

neokobe

Re: XBT reports peers=0 to xbtit
« Reply #10 on: May 31, 2012, 03:30:08 pm »
xbt_files_users, rows 70-89



The majority of the table has columns "completed", "downloaded", "left" and "uploaded" filled with 0.

*

neokobe

Re: XBT reports peers=0 to xbtit
« Reply #11 on: June 07, 2012, 02:56:33 am »
I decided to do everything from scratch following these steps:

1) Uninstall XBT Tracker and delete the service
2) Delete all xbt tables
3) Install XBT Tracker and install as service
4) Created the tables using xbt_tracker.sql
5) Checked "Use XBT as backend" option in xbtit config

The following MySQL error came up, "torrent_pass_secret doesn't have a default value" in table xbt_users



After changing the default value to NULL, the error stops showing.

Is that error caused by latest MySQL version's "features"?

After doing that, I can enable xbt and the numbers of seeders/leechers/peers shows 0. Has this default value anything to do with the peers not showing up? I did change the default value to NULL the first time too .. I'm sorry I forgot to mention that.. I didn't remember.

*

Offline Lupin

  • *****
  • 10,985
  • +0/-0
    • http://www.btiteam.org
Re: XBT reports peers=0 to xbtit
« Reply #12 on: June 07, 2012, 10:18:28 am »
no, it have nothing to do with your previous problem. And since the rows where present in xbtit_files_users (of course the torrent are present too in xbtit_files) the tracker should display the number of peers, but all this is updated by xbtt
Please don't PM me about question already asked in forum!

Help or support requested using PM will be billed 50 euros/hour, minimum 1 hour; support on forum is free.

*

Offline tojoaijo

  • **
  • 38
  • +0/-0
Re: XBT reports peers=0 to xbtit
« Reply #13 on: October 18, 2017, 07:41:59 am »
Hi,
Anyone have a solution of this issue please? :(

 


Powered by EzPortal